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About this Courseware 

This "Basics" courseware is intended to provide students with an understanding of 

the interface shared by all of BS&A Software's applications, and how to execute 

basic commands such as sorting and blocking records, and searching for data. 

General maintenance of your database is also covered. 

The screen shots used in this Basics courseware come from General Ledger, the 

foundation of our Financial Management suite of applications. 

  

This courseware assumes students understand the basics of using a Windows-

based computer, and are comfortable using the keyboard and mouse. Students 

should also be comfortable navigating the file structure of their computer in order 

to create and manage files and folders. Understanding of and experience with 

printing and using a Web browser is also encouraged. 

  

This courseware is not exhaustive in covering every possible scenario or area of the 

application. Its intent is to showcase key areas and procedures that are covered in 

more detail in the software manual, and it has been designed as a reasonable 

outline of the information and order followed during your training on the software.  

BS&A's applications are designed to anticipate every need of your department. As 

not all municipalities have identical procedures, some aspects of this courseware 

may not be necessary, while some of your training might involve scenarios not 

covered by this courseware. Training is tailored to the individual municipality.  

Customers and potential customers have unlimited access to our Tech Support 

department; feel free to contact them at any time with questions. 

 



 

 

  

  



 

  

  Contents 

Basics of BS&A   i 

  

Contents 

Section 1: Interface .......................................................................................................... 1 

Lesson 1.1: Opening the Application ............................................................................ 2 

Lesson 1.2: Title Bar ........................................................................................................ 5 

Lesson 1.3: Menu Bar ..................................................................................................... 7 

Lesson 1.4: Tool Bar ...................................................................................................... 13 

Lesson 1.5: Application Views and Program Table Views Panes .............................. 16 

Lesson 1.6: Work Area .................................................................................................. 18 

Lesson 1.7: Status Bar .................................................................................................. 21 

Section 2: Program Setup ............................................................................................. 23 

Lesson 2.1: Database Setup Tab ................................................................................. 24 

Lesson 2.2: Program Settings Tab ............................................................................... 26 

Lesson 2.3: My Settings Tab ......................................................................................... 28 

Lesson 2.4: Administration Tab ................................................................................... 31 

Section 3: Database Management .............................................................................. 35 

Lesson 3.1: Shared Database Groups ......................................................................... 36 

Lesson 3.2: Adding a Database .................................................................................... 39 

Lesson 3.3: Backing Up and Restoring Databases ..................................................... 41 

Lesson 3.4: Updating Your Program ........................................................................... 45 

Section 4: Record Selection .......................................................................................... 49 

Lesson 4.1: Searching ................................................................................................... 50 

Lesson 4.2: Sorting ........................................................................................................ 57 

Lesson 4.3: Blocking...................................................................................................... 60 

Lesson 4.4: Marking ...................................................................................................... 64 

Lesson 4.5: Setting a Range ......................................................................................... 68 

Section 5: Running Reports .......................................................................................... 71 

Lesson 5.1: Accessing a Report .................................................................................... 72 

Lesson 5.2: Setting Options ......................................................................................... 77 



 

  

  Contents 
ii   Basics of BS&A 

  

Lesson 5.3: Using Filters to Query Your Data ............................................................. 81 

Lesson 5.4: Report Profiles .......................................................................................... 85 

Section 6: Getting Help ................................................................................................. 91 

Lesson 6.1: Interactive Manual .................................................................................... 92 

Lesson 6.2: Contacting Support ................................................................................... 99 

Lesson 6.3: Getting Help with Your Data .................................................................. 103 

 

  



  

 

 

Section 1: Interface 

 

In this section you will learn how to: 

o Open the application 

o Recognize the basic areas that make up the interface of 

a BS&A .NET application 
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Lesson 1.1: Opening the Application 

  

...from the Desktop 

  

1. Look for the Equalizer .NET Applications folder on your desktop and double-click it.  

2. Look for the name of the application you want to open (General Ledger is used in this 

example) and double-click it.  

3. Enter the user name and password (if any) assigned to you and click Login.  
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...from within a .NET Application 

  

1. Open BS&A Applications in the Menu Bar. A list of all installed BS&A applications 

drops down. 

2. Select the name of the application you want to open.  

 

3. The application opens without prompting you to log in. 
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Notes 
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Lesson 1.2: Title Bar 

The Title Bar is located at the top of your BS&A application and is always visible. 

 

  

(1) Name of the application 

  

(2) Name of the currently-logged in user 

  

(3) Name of the currently-active database 

  

(4) Name of the Shared Database Group to which the database belongs (if any; otherwise, 

this says None) 

  

(5) Version date of the application 

  

(6) Windows buttons used to minimize, resize, or exit the application 



 

  

 Section 1: Interface 
6   Basics of BS&A 

  

Notes 
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Lesson 1.3: Menu Bar 

The Menu Bar is located beneath the Title Bar. It, too, is always visible, regardless of the 

screen you are viewing. Most BS&A programs have the same Menu Bar. The availability of 

Tasks and Utilities varies from program to program. 

 

  

The File menu provides options for managing your database (add, open, copy, back up, 

etc.), importing and exporting data (not available in all programs), and exiting the program.  
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The View menu is an alternative to the Application Views pane. It also offers a Back option, 

which is an alternative to the Back button in the Tool Bar, and an option to go to Full 

Screen, which removes the Application Views pane and the Program Table Views pane. 

 

  

The Navigation menu is an alternate way to scroll through your records, conduct searches 

(see page 50), and sort your records (see page 57). 

 

  

The Data Entry menu is an alternative to using the Application Views pane and some of 

the buttons available on the selected data entry screen.  
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The Tasks menu provides items to assist in the day-to-day use of the program.  

 

  

The Reports menu opens up to a list of report categories. When a report category is 

selected, you are taken to the Run Report dialog where you may set up and run a variety of 

reports.  
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The Utilities menu provides items to handle unique situations that surface from time to 

time.  

 

  

The BS&A Applications menu provides a list of installed BS&A programs. Click a program 

to open it (no user name/password entry required). 
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The Help menu provides a variety of options to assist you. 
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Notes 
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Lesson 1.4: Tool Bar 

Tool Bars appear at the tops of Tables, Data Entry screens, some Tasks/Utilities, Reports, 

Program Setup screens, and other areas. Pictured is a Tool Bar that offers a variety of 

buttons, including a Back -  - button: 

 

Following are the most-frequently visible buttons and their functions. Depending on the 

screen, additional buttons will be available and their functions covered where relevant. 
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Buttons vary depending on the screen. Pictured is a typical Tool Bar available when viewing 

a Program Setup screen (in this example, Fund Setup): 
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Notes 
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Lesson 1.5: Application Views and Program Table Views 

Panes 

The Application Views and Program Table Views panes are located on the left side of the 

screen. If these panes are not visible, Full Screen has been selected in the View menu; press 

Alt+Shift+Enter to restore the view. 

The Application Views pane - (1) - displays the different areas that can be reached with the 

click of your mouse or your  and  keys. The Program Table Views pane - (2) - appears 

when you highlight the Tables: item in Application Views. Click the  button in Program 

Table Views to open a list of the different tables available; select the Table you want to 

view. 
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Notes 
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Lesson 1.6: Work Area 

To the right of the Application Views and Program Table Views panes is the work area. The 

information you see depends on the item selected in the Application Views pane. 

  

Example 1 

Manual Journal Entry is selected in Application Views: 
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Example 2 

Tables is selected in Application Views, and GL History is selected as the table: 
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Notes 
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Lesson 1.7: Status Bar 

The Status Bar is located at the bottom of your BS&A application and, while always visible, 

changes depending on the screen currently being viewed (for example, the Sort Index - 

pictured below - disappears when viewing the Program Setup screen). All BS&A programs 

have a Status Bar, but some of its icons and information vary from program to program. 

 

  

(1) When viewing a data entry screen or table, the current sort order of the records is 

shown in the Sort Index. You may click the text to change the sort order (sorting is covered 

beginning on page 57). 

  

(2) In GL, this icon indicates the status of your journal entries. When greyed out, as 

pictured, no unposted journal entries are detected. If unposted journal entries are 

detected, the icon is red - . Other BS&A applications use this icon in a similar fashion.  

  

(3) This globe indicates the status of available software updates (updates are covered 

beginning on page 45). 
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Notes 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  



  

 

 

Section 2: Program Setup 

 

In this section you will learn the layout of the Program Setup screen and some of its generic 

buttons. Buttons/settings relating to a specific application are covered in the relevant 

courseware. 
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Lesson 2.1: Database Setup Tab 

The Database Setup tab provides buttons containing setup screens for the currently-

opened database. 
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Notes 
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Lesson 2.2: Program Settings Tab 

The Program Settings tab provides buttons containing settings, rather than setup items, for 

the currently-opened database. 
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Notes 

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  



 

  

 Section 2: Program Setup 
28   Basics of BS&A 

  

Lesson 2.3: My Settings Tab 

The My Settings tab provides buttons containing settings that affect the currently logged in 

user. 

 

  

My Preferences. Select options to be applied when your user name is logged in. 

  

Change My Password. ("BS&A" user names) Change the password currently assigned to 

your user name. BS&A user names are user names set up in a BS&A application, and are 

separate from your Windows Active Directory user names.  

  

My Auto Login. ("Active Directory" user names) Tell the program to automatically log you 

in without being prompted to enter your Windows Active Directory user name and 

password. Active Directory user names are the user names set up for you to log into your 

network; rather than setting up separate BS&A names, you may populate your user list 

with these Windows Active Directory names. 
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My Color Settings. Change the color scheme of the program for your user name. 

  

Reset Table Settings. Reset tables to the defaults used by the program. 

  

Reset Report Options. Reset report options to the defaults used by the program. 
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Notes 
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Lesson 2.4: Administration Tab 

The Administration tab provides buttons letting admin-level users manage other users and 

their security settings. High-level administrative functions affecting program maintenance 

and updates, as well as the connection between the various applications' databases, is also 

managed on this tab. 

 

  

Users. Add users and manage their individual security. 

  

Password Security. Manage password security for either BS&A users or Active Directory 

users. 

  

User Groups. Add user groups and manage group security (multiple users who have 

identical custom security). 

  

Custom User Labels. Relabel the two user fields on the User Setup screen. 
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User Setup Lists. Set up list items for the two user fields on the User Setup screen. 

  

Active Directory Auto Login. Select whether and how to use Active Directory auto login. 

  

Program Update Security. Set rights for running updates from within the program. These 

settings are necessary when the users running the programs may not have administrator 

rights to their own PCs. 

  

Dept/Fund Access. (Selected BS&A programs) Restrict access to specific funds, 

departments, accounts, and projects. 

  

Shared Program Folder. Specify the path to the Shared Program Folder, which is used to 

store program updates, the program manual, backups, and - in some cases - attachments. 

  

Who's Logged In. View users currently logged into the program. You may send a message 

to all or selected users, and log users out if necessary. 

  

Zip Code Maintenance. Add a city/state/zip code record for use with the Zip Code Lookup 

feature. 

  

Shared DB Settings. Add and manage Shared Database Groups. 
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Notes 
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Section 3: Database Management 

 

In this section you will learn about: 

o Shared Database Groups 

o Adding a database and attaching it to a Shared 

Database Group 

o Backing up and restoring databases 

o Updating your database 
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Lesson 3.1: Shared Database Groups 

Shared Database Groups allow you to minimize your BS&A .NET database management by 

linking the databases. Databases are not required to belong to Shared Database Groups, 

but linking your databases lets you take advantage of the numerous data sharing and 

exchange capabilities within BS&A's .NET programs. For example, the General Ledger 

database will receive journal entries from other BS&A applications as they are created. 

A Shared Database Group only needs to be set up once; it will be accessible to all installed 

BS&A .NET applications. 

  

1. Go to Program Setup>Administration>Shared DB Settings. 

2. Verify Current Database is displaying your currently active (working) database. 

3. Click . 

4. Enter the name of the new Shared Database Group and click Ok.  

 

Show Only Applications that [app name] Can Interact With is checked by default, 

displaying only those (installed) BS&A .NET applications that link with the one you 

currently have open.  
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5. (Optional) Click Advanced to allow this Shared Database Group to be used by multiple 

databases in the current BS&A application. For example, this would allow multiple 

Tax databases to post to a single General Ledger database. 

i. Check the Allow Multiple Databases for Each Application box. 

ii. Click Close to return to the setup screen. 

6. Click Set Shared Database Group to Use Current Database, then Yes. 

7. Click Close. 

8. You are prompted that any other currently-open BS&A .NET applications will need to 

be closed and restarted for the change to take effect; click Ok. All users that have 

affected BS&A .NET applications open will need to exit and restart. 
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Notes 
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Lesson 3.2: Adding a Database 

  

1. Go to File>Database>New Database. 

2. Enter the name of the new database and click Ok.  

3. You are prompted to make this new database your current database (the current 

database is your working database); answer accordingly. 

4. (Optional) Attach this database to the appropriate Shared Database Group: 

i. Verify your database is your active (working) database: 

 

ii. Go to Program Setup>Administration>Shared DB Settings. 

iii. Select the Database Group Name. 

iv. Click Set Shared Database Group to Use Current Database, then Yes. 

v. Click Close. 

vi. You are prompted that any other currently-open BS&A applications will need to 

be closed and restarted for the change to take effect; click Ok. All users that 

have affected BS&A applications open will need to exit and restart. 
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Notes 
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Lesson 3.3: Backing Up and Restoring Databases 

  

Back Up a Database 

  

1. Go to File>Database>Backup Database. 

2. Database to Back Up defaults to the currently-active database and can be changed. 

3. Enter or browse to the folder in which to save the file and click Save. 

A file name is automatically supplied in the Save Backup As field, identifying the BS&A 

application, the database being backed up, and the date the backup is being created; 

we recommend using this name. 

 

4. Click Ok. If the name of the backup file already exists, you are prompted to overwrite 

it. 
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Back Up a Shared Database Group 

  

1. Go to Program Setup>Administration>Shared DB Settings. 

2. Select the Database Group Name. 

3. Click Backup Entire Group. 

4. Current Database Group reflects your selection in step 2. 

5. Enter or browse to the folder in which to save the file and click Ok. 

A file name is automatically supplied in the Save Backup As field, identifying the 

group name and the date the backup is being created; we recommend using this 

name. 

 

6. A dialog pops up listing the programs and databases being included; provided this list 

is correct, click Yes. 
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Restore a Database 

Databases can be restored from individual database backups, or from Shared Database 

Group backups, and can be restored to an existing database or as a new database. 

  

1. Go to File>Database>Restore Database. 

2. Browse to the Database Backup File (whether an individual database backup file or a 

Shared Database Group backup file) and double-click it. 

3. Select the Restore Option:  

o Restore to Existing Database. The files in the backup will overwrite the files in 

the selected database.  

o Restore to New Database. Enter the name of the new database. 

4. Click Ok. If restoring to an existing database, you are prompted that it will be 

overwritten; click Yes. 

 

5. You are prompted that the restore is complete, and asked to select whether or not to 

make this the active database; answer accordingly. 
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Notes 
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Lesson 3.4: Updating Your Program 

Installing updates can be user-restricted (Program Setup>Administration Tab>Program 

Update Security). 

  

Update Manager 

The Update Manager lets you view a log of updated items, broken down into Critical, High 

Priority, Medium Priority, and Low Priority. You may select from Only Show Update Entries 

Newer Than My Program Version or Show Update Entries for the Following Number of 

Days. The bottom of the Update Manager displays your current version date and the 

version date of the update available on our website. 

  

1. Click the button in the lower-right corner of your BS&A application's screen: 
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2. Click , then Yes. The application shuts down. The update downloads from 

our website and automatically runs. 

3. When finished, re-open the program. 

  

Help Menu 

  

1. Go to Help>Download Latest Version.  

2. Select Automatic Download. The program shuts down. The update downloads from 

our website and automatically runs. 

3. When finished, re-open the program. 
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Notes 
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Section 4: Record Selection 

 

In this section you will learn how to: 

o Search 

o Sort records 

o Block records 

o Mark records 

o Set a range of records 
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Lesson 4.1: Searching 

  

List Records Button 

Located on most setup screens. Click  to bring up a list of items and select the item you 

want to view. Rather than scrolling through the list, use the Sort Index field to aid you in 

your search. To illustrate this, let's say you know the name of the fund you want to search 

for, but are unsure of the fund number. Change the Sort Index to Description and start 

typing. As you type a character, the cursor jumps to the first record it finds: 

 

  



 

  

 Section 4: Record Selection 

Basics of BS&A   51 

  

Navigation Menu 

  

1. Go to Navigation>Search or Navigation>Quick Search: 

o Search (the fields available for searching depend on the data you are viewing) 

i. Select the field by which to search. 

ii. Enter the search criteria and click Ok. 

iii. If the Search Results screen appears, locate the record you want to view 

and select it. 

o Quick Search 

i. Click the quick search field (another option is to press the Function key 

assigned to the search field without going through the Navigation menu). 

ii. Enter the search criteria and click Ok. 

iii. If the Search Results screen appears, locate the record you want to view 

and select it. 

  

Page Up and Page Down Buttons/Keys 

Located on data screens and setup screens. Click the appropriate button -  - or use 

your PgUp and PgDn keys. In data screens, the records presented are affected by the 

current sort index (see page 57). In setup screens, the records presented are always in 

numeric or alphabetical order, depending on the type of setup screen. 

  



 

  

 Section 4: Record Selection 
52   Basics of BS&A 

  

Quick Search; Function Keys 

Quick Search uses Function keys and occasionally, a hotkey combination. Some 

BS&A applications provide a Quick Search list in Application Views. 

  

1. Click the green quick search command link (1) or press the assigned Function key (2).  

 

2. Enter the search criteria and click Ok. 

3. If the Search Results screen appears, locate the record you want to view and select it. 

  

Search Button or Alt+S  

The fields available for searching depend on the data you are viewing.  

  

1. Click  or press Alt+S. 

2. Select the field by which to search.  

3. Enter the search criteria and click Ok. 

4. If the Search Results screen appears, locate the record you want to view and select it.  
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Table Searches 

As with the List Records method illustrated at the beginning of this topic, when viewing a 

table you may start typing the data you are searching for, subject to the current index (sort 

order). A search template appears at the bottom of the screen to accept the entry. Pictured 

is an example using the All Journal Entries table in General Ledger. The table is sorted by 

transaction number. As you type a character, the cursor jumps to the first record it finds. 
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Search Results Screen 

When executing a search, and multiple records are found (for example, a search on Smith) 

a Search Results screen appears: 

 

This screen can be resized, and its columns resized and reordered. The screen will retain 

those settings until you reset them to their original state. Search Results screen settings are 

unique to each user name. 

  

To resize the screen... 

i. Position your cursor along a border of the screen. Depending on your cursor 

location, the cursor will appear as one of the following:  

 

Tip: use the diagonal (appears when positioned on a corner); this stretches out and 

down (or up). 

ii. Press and hold your left mouse button and drag your mouse to stretch the screen; 

release it when you've achieved the size you want. 
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To resize the columns... 

i. Position your cursor in the column heading between the column you want to resize 

and the column to the right. Your cursor changes to:  

 

ii. Press and hold your left mouse button and drag your mouse to the right; release it 

when you've achieved the width you want. 

  

To reorder the columns... 

This enables you to move columns around until they are in the order you like; it is not the 

same as re-sorting the records. 

i. Position your cursor in the column heading of the column you want to move.  

ii. Press and hold your left mouse button and drag your mouse left or right. A pixelated 

border appears to indicate the column is being moved:  

 

iii. Release the mouse button when the column is in the position you want. 

  

To reset columns to their original state... 

 To reset the current Search Results screen's columns, click the Reset Columns 

command link, then Yes.  

 To reset all Search Results screens (and tables), go to Program Setup>My Settings and 

click Reset Table Settings. Check the Yes, I wish to... box and click Ok. This affects both 

the size and the columns. 
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Notes 
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Lesson 4.2: Sorting 

The sort order, or index, of records is important when setting ranges for reports and when 

blocking off records. The fields available for indexing depend on the data you are viewing. 

When viewing a table, the primary index appears in red and is the left-most column (1), 

unless you have moved it to another position. The index is also displayed in the Status Bar 

(2), whether you are viewing a table or a data entry screen, as illustrated on page 21. 

  

  

Column Heading (Table View). While viewing a table, double-click the column heading of 

the field by which you want to sort.  

  

Ctrl+I or Alt+I Keys. Press Ctrl+I or press Alt+I and select the field. 

  

Index Button. Click  (available whether viewing a data screen or a table) and select the 

field.  
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Navigation Menu. Go to Navigation>Index and select the field. 

  

Right-Click Menu (Table View). While viewing a table, position your cursor anywhere on 

the table and right-click to receive a menu; click Change Index and select the field. 

  

Status Bar. Click the button representing the current sort order - for example, 

- and select the field. 
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Notes 
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Lesson 4.3: Blocking 

Blocking records is useful for reports and certain other operations. Blocked records appear 

highlighted in red. 

  

Block  

  

1. Open the table and sort by the field that will determine the block. 

2. Determine your method: 

o Use the button in the Tool Bar: 

i. Highlight the first record to be included in the block. 

ii. Click . The button changes to Block End. 

iii. Highlight the last record to be included. 

iv. Click . The button changes to Block Clear. 

o Use the right-click menu: 

i. Position your cursor on top of the first record to be included in the block. 

ii. Right-click and select Block Start. 

iii. Position your cursor on top of the last record. 

iv. Right-click and select Block End. 

o Use your Shift key: 

i. Click the first record to be included in the block. 

ii. Press and hold your Shift key. 

iii. Click the last record to be included and release your Shift key. 
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Quick-Block  

The Quick-Block option lets you quickly set a block by entering parameters dependent 

upon the current sort order.  

  

1. Open the table containing the records you want to block. 

2. Click . 

3. Verify or select the Sort Index (if changed here, that change will be made on the table 

as well).  

4. Enter the Start Value and End Value.  

 

5. Click Ok. 
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Increase/Decrease Number of Blocked Records 

  

To increase... 

1. Click the unblocked record that is to be the last. 

2. Click the  part of the Block Clear button and then Block End. 

OR 

1. Press and hold your Shift key. 

2. Click the unblocked record that is to be the last and release your Shift key. 

  

To decrease... 

1. Click the blocked record that is to be the last. 

2. Click the  part of the Block Clear button and then Block End. 

OR 

1. Press and hold your Shift key. 

2. Click the blocked record that is to be the last and release your Shift key. 

  

Clear a Block 

Three options are available: 

  

o Click  

o Right-click and select Block clear 

o Change the index of the records (see page 57) 
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Notes 
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Lesson 4.4: Marking 

Marking lets you flag random records and is useful for reports and certain other 

operations. Marked records appear highlighted in bright blue. 

  

Mark One or a Few Records  

  

1. Open the table containing the records you want to mark.  

2. Highlight the record to mark.  

3. Determine your method: 

o Use the button in the Tool Bar: 

i. Click  and select Mark Selected Record. 

o Use the right-click menu: 

i. Position your cursor on top of the record. 

ii. Right-click and select Mark Selected Record. 

o Use your Ctrl key: 

i. Press and hold your Ctrl key. 

ii. Click a record. 

o Press your spacebar. 

4. Repeat the selected method on the remaining records to be marked.  

  

Mark All or Blocked Records  

  

1. Open the table containing the records you want to mark. 

2. Click the  part of the Mark button to receive a list of options.  

3. Click Mark All Records or Mark Current Block.  
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Quick-Mark  

  

1. Open the table containing the records you want to mark. 

2. Click .  

3. Verify or select the Sort Index (if changed here, that change will NOT be made on the 

table).  

4. Enter the Value and click Mark Record.  

 

If more than one record is found with that value, you will receive a Search Results 

screen; double-click the appropriate record.  

5. Click Close. 
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Unmark Records 

  

To unmark one record... 

o highlight it and press your spacebar  

OR  

o position your cursor on top of the record, right-click, and select Unmark Record. 

OR 

o press and hold your Ctrl key on the marked record and click 

  

To unmark all/blocked records... 

o click the  part of the in the Mark button and select Unmark All Records or Unmark 

Blocked Records.  
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Notes 
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Lesson 4.5: Setting a Range 

Setting a range is done when running reports or performing some tasks and utilities. The 

fields available for selection depend on the current sort order. For example, I want to run a 

Chart of Accounts report for only accounts between 101-215-702.000 and 101-257-956.000 

(running reports is covered in more detail in Section 5 of this courseware): 

  

1. Open the Chart of Accounts table and sort by GL Number. 

2. Go to Reports>General Ledger Reports. 

3. Select Chart of Accounts as the Name. 

4. Click Report Options. 

5. Select Range (using current index) as the Population and click Yes. 

6. Enter the range and click Ok:  

 

7. Click Ok to close Report Options.  

8. Select the print Destination and click Run Report. 
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Notes 
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Section 5: Running Reports 

 

In this section you will learn how to: 

o Access a report 

o Set report options 

o Set filters for more robust reporting 

o Set up and use Report Profiles 
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Lesson 5.1: Accessing a Report 

  

Reports Menu 

The Reports Menu drops down a list of Report Categories, each of which contains its own 

set of reports: 
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Upon selecting a Report Category, the Run Reports dialog appears. You may select another 

category from within this dialog (1). Individual reports (dependent upon the selected 

category) are selected in the Name field (2): 
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The Show Sample Reports option (3) lets you preview the report before printing it (this can 

also be accomplished by selecting Screen as your Destination). Use the Zoom scale (4) to 

adjust the view. 
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Print Button 

Some screens provide a  or  button, which offers a smaller dialog, as it's 

tailored to a specific report or printout. For example, clicking  on your Banks setup 

screen yields this dialog: 
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Notes 
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Lesson 5.2: Setting Options 

BS&A strives to make your job easier by providing the most frequently-used filters for 

reports in a Report Options dialog. Pictured is the Report Options dialog for a Journal Entry 

Report: 

 

You can open the dialog by clicking the Report Options button on the Run Report dialog. A 

user setting, however, can ensure you never overlook this screen (see "Display Report 

Options," below). 
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Among the filters for each report, you can select the population of records on which to run 

the report. The previous section of this courseware - "Record Selection" - illustrates how to 

mark and block from a Table. You may do so directly in a Report Options dialog: 

 

Once records are marked or blocked, clicking the Population Options button lets you alter 

the selection or remove the mark/block entirely. 

  



 

  

 Section 5: Running Reports 

Basics of BS&A   79 

  

Display Report Options 

Program Setup>My Settings>My Preferences contains a setting letting you tell the program 

to Display Report Options Dialog Before Each Report Run. By default, this setting is 

checked, meaning you will not need to click the Report Options button prior to running a 

report, because the report options dialog will automatically pop up when you click the Run 

Report button. 
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Notes 
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Lesson 5.3: Using Filters to Query Your Data 

Filters are used to query your database for specific information. For example, we want a 

report of all General Ledger Accounts using the Account number 702.000. 

  

1. Go to Reports>General Ledger Reports>Chart of Accounts. 

2. Click Report Options. 

3. Select All Records as the Population. 

4. Check the Apply Advanced Query to Population box and click Advanced Query. 

5. Click  in the Filters pane (left side). The Edit Filter Condition dialog appears. 

 

 Table. Some reports allow the selection of a table; others, as in this example, do 

not. The table contains the data you are querying. 

 Field. Used to select the specific field you are querying. The Search for a Field 

button can be useful when table selection is allowed, as you may know the field 

name, but be unsure to which table it belongs. If you've marked any fields as 

"favorites," you may click the Select a field from your report favorites command 

link to select it. 

 Operator. Used to set the condition for the comparison between the data and 

the input. 



 

  

 Section 5: Running Reports 
82   Basics of BS&A 

  

 Compare To. Used to set the parameters for the query. 

6. Select your options and click Ok. 

7. Select the Report Data Must Match option. In general, "All" means the data found by 

the query must match Filter A and Filter B. "Any" means the data found by the query 

must match Filter A or Filter B. The same is true on the right side of the screen. 

Multiple conditions can be set for each filter in the query, using the same AND/OR 

search. 

 

8. Click Close to return to Report Options. 

9. Click Ok to return to the Run Report dialog. 
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10. Select Screen as the Destination and click Run Report. Your query is applied: 
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Notes 
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Lesson 5.4: Report Profiles 

  

In General... 

Report Profiles let users group their most-often run reports together for quick retrieval 

when reporting. Report Profiles store the filters most often used for each report, the 

Destination (screen, printer, file, or image), and the printer. 

o Use Same Report Options for All Users That Run This Profile (1). If checked, the report 

options set up for the reports in the selected Report Profile will be used regardless of 

which user is printing. If unchecked, each user can set up his own report options. 

o Set Global Options (2). (Available in selected applications). Click this button to set 

general options to be applied to all reports in the profile. For example, if all reports in 

the profile should be run on a specific date range, set that range here rather than 

repeating that setup in the Options screen of each report in the profile. 
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Set Up a Report Profile 

  

1. Go to Reports>Report Profiles.  

2. Click the  button located on the LEFT side of the screen.  

i. Enter the Profile Name and click Ok. 

3. Click the  button located on the RIGHT side of the screen.  

i. Select the Report Category and the Report Name.  

ii. Report Display Name combines the category and report and can be changed at 

this point or at any time by clicking the Rename button located above the list of 

reports. 

iii. Click Add to Profile. 

 

iv. Select any other reports that you would like to add to the current profile. 

v. Click Close. 

4. Click the Options button that appears to the right of a report name. 

i. Click Report Options.  

ii. Set the filters that will be used for this report when run from the current 

profile.  

iii. Click Ok, then Close. 



 

  

 Section 5: Running Reports 

Basics of BS&A   87 

  

5. Click .  

i. Select the printer that will be used for all reports in the current profile.  

ii. Click Ok to return to the Report Profiles screen.  

6. Select the default Destination (screen, printer, file, or image) where all reports in the 

current profile will print. 

7. Select whether or not to Show Options for All Reports Before Running. 

8. Click the Run button that appears to the right of the Options button to test the 

output. Another option is to add the reports and their options for the current profile 

and then click Run All Reports to test them at once.  
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Use a Report Profile 

  

1. Go to Reports>Report Profiles.  

2. Click the Report Profile you want to work with.  

3. Click the  button of the report or reports you want to run and verify their 

settings.  

4. Run the report(s):  

o To run the reports individually, click the appropriate  button to the 

right of the Options button (1).  

o To run all reports at once, click the  button located toward 

the bottom of the screen (2). 
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Notes 
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Section 6: Getting Help 

 

In this section you will learn how to: 

o Use the interactive manual 

o Contact support in a variety of ways 

o Get help with your data via Remote Assistance or FTP 

Due to impending changes in our help system and our 

website, videos corresponding to the Lessons in this Section 

have not been created. 
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Lesson 6.1: Interactive Manual 

The manual is an electronic, interactive version of a traditional printed manual, and is 

available in the Help menu. Changes and updates to the manual are ongoing; therefore, we 

recommend users periodically download the latest version: 

 

The Manual is best viewed in IE9, FireFox, or Google Chrome. If you are running IE8, you may 

experience functionality issues and will need to disable Compatibility Mode (our I.T. support can 

assist with this). 
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Contents Tab 

The Contents tab is the Table of Contents, and is very easy to navigate.  
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Search Function 

Search for a keyword, and topics found are clearly listed (1). When you visit a topic, the 

keyword is highlighted so you may easily find what you're looking for (2). Click the  

button to remove the highlight (3). 
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Breadcrumbs 

Breadcrumbs appear at the top of each topic (1), letting you know where you are even 

when the source isn't visible in the Contents tab. Links to the "umbrella" topics and heading 

topic (2) let you quickly navigate back: 
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FAQs 

The FAQs page presents questions commonly asked by users, with links to the appropriate 

topics in the manual: 
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Immediate Access to Support 

Located throughout the manual are notes where assistance of Support is recommended or 

required. Click the Support link to view options. Click the email link to immediately launch 

your email program; click the website link to be taken directly to our website. 

 

  

Print and PDF Versions 

Print and PDF versions of the manual are available upon request, but please be aware that 

they are not updated as frequently as the electronic version in the program. 
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Notes 
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Lesson 6.2: Contacting Support 

  

BS&A Application Help Menu 

You have two options, both of which submit your request directly into our contact 

management database. 

  

Help>Contact Customer Support>Request Support Phone Call. Fill out the information 

and click Submit. 
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Help>Contact Customer Support>Email Support. Your email program launches, 

automatically filling out the appropriate To contact, and providing basic information in the 

Subject line. Type your message (please be sure to include a phone number where you can 

be reached) and click Send.  

 

  

Phone 

Locally, you may call (517) 641-8900, or use our toll-free number: (855) BSA-SOFT (272-

7638).  

Inform the receptionist of the program with which you need help and you will be directed 

to the appropriate department or support rep. 

  

Fax 

(517) 641-8960 

Please include a cover when faxing so we can ensure the document gets to the appropriate 

department or support rep. 

  



 

  

 Section 6: Getting Help 

Basics of BS&A   101 

  

Website 

www.bsasoftware.com 

Click the red Contact button on our main page. Fill out the information and be sure to 

select the appropriate department: 
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Notes 
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Lesson 6.3: Getting Help with Your Data 

  

Remote Assistance 

Over the phone, a support rep will direct you to go to Help>Remote Assistance. Inform the 

support rep of the ID and the rep will direct you to proceed. 
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FTP 

Go to Help>FTP>FTP File to BS&A Software. File to Upload defaults to the location of the 

last backup made by the user. Backups are the most common files sent to us; by defaulting 

to this location, you can make the backup and then immediately send it to our FTP site 

without having to search for it first. Inform the appropriate support rep that the file has 

been uploaded. 
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Notes 
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